error: could not install smartsocket listener: Address already in use

This article is about error message: “error: could not install smartsocket listener: Address already in use”.

I like to flash my android smartphone. As we all know, there are (at lease) two tools we could use when flashing phones: adb and fastboot. But I met a problem when I try to run new adb server, it keep showing the this message in my terminal:

The Message “error: could not install smartsocket listener: Address already in use”

“Address already in use? so there must be someone using the address I need.” I thought, “ok, let me find the criminal”

and I gave terminal a command ps aux | grep adb to show all processes which is including adb word, then I got:

Readmore